Jump to content





Posted Image

PCS & Stuart M. Grant - Cichlid Preservation Fund - Details here

International Guest 2019 - Larry Johnson - Canada - Details here

December PCS Meeting  - Quiz, Bingo & Movie Night - Tues December 4th - Details soon

December Fish of the Month - Placidochromis electra - Details here

November Photo Comp - Tanganyikan Cichlids - Enter Now! - Details here


Photo

New Member Introduction!!


  • Please log in to reply
1 reply to this topic

#1 M.Cross

M.Cross
  • Forum Member
  • Joined: 13-June 16
  • Location: Two Rocks

Posted 14 June 2016 - 07:54 PM

Hey fellow aquarium enthusiasts!!!

My names Mitch, I'm 27 and I'm just starting to get more serious about my love for aquariums!!

I've got a question about my EHEIM 600..

After shifting houses I've decided to set my tank up again but I'm having problems priming my canister.... I've done all the usual things to get the water flow happening but it's just not working......... I then noticed that the bottom intake, where it comes out of the canister is actually moving.... Like it can swivel around 360*..... I can't remember if this is the way it's suppose to be or if it's been damaged during the move...

Does everyone else's move around like this?? Or am I going to have to convince the missus I need a new one??

Cheers

#2 Chopstick_mike

Chopstick_mike
  • Forum Member
  • Joined: 31-March 15
  • Location: Tapping

Posted 14 June 2016 - 08:28 PM

Can you get it flowing if the return pipe is pointing down in a bucket ??
If so plug it with your thumb then plug the filter in and it should keep going if not it might be your impeller




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users