Jump to content





Posted Image

PCS & Stuart M. Grant - Cichlid Preservation Fund - Details here

PCS Photo Comp 2018 - Enter to Win Prizes - Details here

September PCS Meeting  - DIY, Snails, Rays and Plants - Tues September 4th - Details here

September Fish of the Month - Neolamprologus similis - Details here

September Photo Comp - Tankbusters, Oddballs & Exotics - Enter Now! - Details here


Photo

Tank Treatments


  • Please log in to reply
3 replies to this topic

#1 chrishaigh82

chrishaigh82
  • PCS Club Member
  • Joined: 02-February 16
  • Location: South Perth / Canning Vale

Posted 11 July 2017 - 10:33 PM

I've had a few major ammonia spikes in my tanks over the years of keeping moderate->heavy stocked cichlid tanks.  Unfortunately we had one today in our 8 footer (no victims by the looks of it but a 80% change was the trick today).  We are only one week after a clean and water change, the same quantity of food (scoops) that we have applied to the tank for two years 3 x/week however today we put in some Accu-clear to clear up the water.

 

We are well aware that ammonia build up can present with discolouration to the tank water however this isn't the first time we've had a spike after treating with a flocculant.  Have others had the same experience after dosing tanks with Accu-clear or equivalent?

 

I need to have a read as to the mechanism of the chemical we are dosing I guess.



#2 Delapool

Delapool

    Membership Officer

  • Admin
  • Joined: 10-July 15
  • Location:Viveash
  • Location: Viveash

Posted 12 July 2017 - 07:20 AM

I've used seachem clarity (not sure if same) a few times on tank re-scapes or after adding substrate. No issues - haven't tested a lot though thinking about it, usually too knackered after working in tank.


Sent from my iPhone using Tapatalk

Edited by Delapool, 12 July 2017 - 07:21 AM.


#3 chrishaigh82

chrishaigh82
  • PCS Club Member
  • Joined: 02-February 16
  • Location: South Perth / Canning Vale

Posted 14 July 2017 - 10:53 PM

At home in the last two days my tropheus tank had unresolved particulates and was dosed with the recommendation on the bottle resulting in cloudy water and sad fish.... ammonia thru the roof   :(

 

Acc-tually going to throw this water treatment in the bin. 

 

 

Maybe we have a dodgy batch.


Edited by chrishaigh82, 15 July 2017 - 06:52 AM.


#4 Delapool

Delapool

    Membership Officer

  • Admin
  • Joined: 10-July 15
  • Location:Viveash
  • Location: Viveash

Posted 15 July 2017 - 05:28 AM

Just checking but no other changes in tropheus tank? No big filter cleans or gravel vacs, etc at same time.

I was guessing the cloudy water you think is a bacterial bloom?

I can probably run some checks on seachem clarity to see if anything happens. Half the time when I've dosed the water has been pea soup (thank-you API laterite clay) so I'd never notice cloudy water.

Sent from my iPhone using Tapatalk

Edited by Delapool, 15 July 2017 - 05:30 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users